分类: Python

Win10下pip安装lxml包报错:Microsoft Visual C++ 9.0 is required Unable to find vcvarsall.bat

在Win10x64下使用pip安装lxml包的时候提示报错:Microsoft Visual C++ 9.0 is required (Unable to find vcvarsall.bat)Win7下安装其他一些包也可能出现此问题:

环境:win10 x64 ,python2.7 ,VS2012

原因:windows下使用pip安装包的时候需要机器装有vs2008,VS2012还不行,如果不想装VS2008的话,可以安装一个Micorsoft Visual C++ Compiler for Python 2.7的包

下载地址:
Microsoft Visual C++ Compiler for Python 2.7
http://www.microsoft.com/en-us/download/details.aspx?id=44266

升级pip
python -m pip install --upgrade pip
安装
pip install lxml==3.6.0
即可;
lxml.png
python.png

相关文章

发表新评论